Pump out problems

BillyK

Active member
Member
Joined
Dec 6, 2006
Messages
1,144
Hi ,


I have a stinky problem. I'm having issues getting my holding tank pumped out. I found my vent was clogged and replaced or cleaned all the parts and it vents like new. I checked the suction hose which is three years old and it is not clogged. I can't get the 90 off the tank, but it appears the tube is still attached. I don't know what could be the problem. Has anyone had trouble pumping out and found sludge at the bottom to be the cause. If so what was the solution?


Thanks


Billy K.
 

PascalG

Moderator
Member
Joined
Sep 16, 2003
Messages
11,640
You said “can’t get the 90 off the tank but it appears the tube is still attached”.

I assume this means you have a dip tube at the top and not a fitting a the bottom. If so, and if you are sure there are no vacuum leaks in the hose and pump out out fitting connections, the problem has to be the tube.

When you connect the pump out, try listing for any vac leak at the fitting or at the top of the tank
 

BillyK

Active member
Member
Joined
Dec 6, 2006
Messages
1,144
You said “can’t get the 90 off the tank but it appears the tube is still attached”.

I assume this means you have a dip tube at the top and not a fitting a the bottom. If so, and if you are sure there are no vacuum leaks in the hose and pump out out fitting connections, the problem has to be the tube.

When you connect the pump out, try listing for any vac leak at the fitting or at the top of the tank
Will do. I have the truck coming back Wednesday, so I can be there. Thanks
 

BillyK

Active member
Member
Joined
Dec 6, 2006
Messages
1,144
There is a product called NOFLEX DIGESTER that I use and it truly breaks up the sludge and oxygenates the tank.
I bought a product at my go to plumbing supply. It's called Bio-Clean. I'm told it will do the same thing. Thanks
 

BillyK

Active member
Member
Joined
Dec 6, 2006
Messages
1,144
Pump out today was successful. I'll never be sure what was the secondary problem, but the vent was clogged for sure. No question the Bio-Clean helped the sludgy bottom and I will continue to use it.

Thanks for your solutions,
Billy K.
 
  • Like
Reactions: Cam
Top